Skip to main content

版本检查

视频教程

LumenPnP最近进行了更新,由V4.0.1升级到V4.1,因此请根据你机器的版本选择对应文档教程。 按照下面方法判断你的机器版本。

查找第二辅助校准板

  • 第二辅助校准板位于平台底板上摄像头的下方。
  • 它位于平台底板上的主要校准板对面。
  • 它是一个中间位置有个金色小原点的方形PCB,固定在一个小型安装支架中。

如果你看到第二辅助校准板

说明你的机器是最新板,你来对了指南。继续检查: ✅ 继续进行安装和调试→

如果你没有看到第二辅助校准板

你很可能用的是LumenPnP V4.0(旧版)。你有两个选择:

选项1——继续使用V4.0文档

如果你更愿意保留当前配置,可以继续使用V4.0指南。 请访问:V4.0 文档 这些文档是为你的版本制作的。

选项2——安装第二辅助校准板进行升级(推荐)

升级您的LumenPnP V4.0,之后,您可以使用最新的OpenPnP版本(V2.6-2026最新版,旧版使用2013版本),以及更好的校准方式。
  1. 第二辅助校准板:
    • 价格不到15元
    • 它不需要拆解机器
    • 几分钟内安装
    • 安装后,可以继续参考本指南,体验最佳校准方式
  2. 查看购买第二辅助校准板升级套件→

安装OpenPnP

视频教程

我们支持最新的稳定版OpenPnP v2.6(2026最新版),建议安装该版本。下载链接如下:

Linux(Ubuntu)

  1. 下载Linux版OpenPnP
如果你还没有安装Ubuntu(建议安装Ubuntu 22.04 LTS版本),请按照官方指南操作:安装Ubuntu Desktop。 之后下载OpenPnP安装包 要正确在linux上运行 OpenPnP,需要提前做以下配置:
  1. 安装Java
  2. OpenPnP 需要 Java 运行:
Text
把你的用户添加到拨号组
  1. 这使得 OpenPnP 能够与机器通信:把[USERNAME]替换成你的Linux用户名,
Text
在软件的下载目录打开命令终端,输入下面命令,
Text
然后重启电脑。

Windows

(支持但不推荐)
  1. 下载Windows版OpenPnP
选择对应版本安装
OpenPnP的最新版本 已不再支持 MacOS。如果你现在用的是Mac,你需要切换到Linux或Windows。

下一步

OpenPnP 现已安装并创建了配置文件。这意味着它已经准备好导入我们的配置文件了。点击下方继续。 导入配置文件→

导入配置文件

视频教程

下载LumenPnP 4.1的配置文件:

windows和linux共用一个配置文件,下方点击下载
  1. 解压。你应该能找到两个文件:
    • machine.xml
    • vision-settings.xml
  2. 这些配置文件将取代 OpenPnP 同名的默认配置文件。

完全关闭 OpenPnP


找到.openpnp2文件夹

OpenPnP 将其配置文件存储在一个名为:.openpnp2的文件夹中 Linux(Ubuntu)
  1. 打开你的Home文件夹
  2. 点击显示隐藏文件 或者 使用快捷键 Ctrl + H
  3. 找到并打开文件夹.openpnp2
图片展示了在Linux(Ubuntu)系统中找到的.openpnp2文件夹内容。文件夹内有多个XML文件,如boards.xml、machine.xml、packages.xml等,以及log、scripts、themes文件夹。其中machine.xml文件大小为52.3 KB,packages.xml文件大小为7.3 KB,script-state.xml文件大小为24 KB,vision-settings.xml文件大小为27 KB。该图片与上文“找到.openpnp2文件夹”内容对应,直观呈现了文件夹中文件和文件夹的名称及大小等信息。 Windows
  1. 打开文件资源管理器
  2. 点击查看
  3. 勾选 隐藏的项目
  4. 导航至:C:\Users\[你的电脑用户名]\.openpnp2
图片展示了Windows系统中文件资源管理器的界面。在“查看”选项卡下,有“导航窗格”“详细信息窗格”等窗格选项,以及“布局”“排序方式”“当前视图”“显示/隐藏”等设置。其中,“显示/隐藏”区域的“隐藏的项目”选项被红色框突出显示。该图片与文档中“找到.openpnp2文件夹”部分的Windows操作步骤相关,用于指导用户在文件资源管理器中勾选“隐藏的项目”选项,以便找到隐藏的.openpnp2文件夹。

替换配置文件

在 .openpnp2 文件夹中,你会发现几个 XML 文件。
  1. 找到这两个文件:
    • machine.xml
    • vision-settings.xml
  2. 用你前面下载的两个文件替换它们。
    • 它们应该有同一个名字。
    • 把文件复制粘贴到.openpnp2文件夹里
    • 它会提示你覆盖当前文件。选择同意覆盖。

验证已加载的配置

  1. 启动OpenPnP
    • 等待其完全加载运行
    • 确认软件能够正常显示主界面
  2. 如果OpenPnP成功启动,说明配置文件是正确导入的。

建立联接

视频教程

机器通电

  1. 连接前,确保LumenPnP已通电。
    • 控制器板应该已经通过USB连接到你的电脑了。

软件中文

修改后,重启生效。本文档教程中使用的英文界面,请仔细甄别每个操作步骤。 图片展示了OpenPnP软件界面中“View”菜单下的“Language”选项及子菜单。其中“Chinese (China)”选项被红色框和箭头突出显示。这与文档中“选择串口”步骤相关,文档提到在选择可用的串口时,需在OpenPnP软件中找到“Machine Setup>Drivers>GcodeDriver>Configuration”下的“Port”下拉菜单,此处图片直观呈现了该菜单及“Chinese (China)”选项,帮助用户在软件中进行相应操作。

选择串口

  1. 启动 OpenPnP
  2. 找到Machine Setup标签页
  3. 在窗口中,打开Machine Setup > Drivers > GcodeDriver > Configuration
  4. 找到下拉菜单Port
  5. 选择可用的串口
    • Linux的典型端口名称:/dev/ttyACM0(或除0以外的其他数字)
    • Windows的典型端口名称:COM3, COM4, COM5, etc.

连接机器

  1. 点击机器控制面板中的绿色电源按钮。
  2. 如果连接成功:
    • 机器将启用
    • home回零图标将变成黄色
    • 绿色电源键现在变成了红色
  3. 这表明OpenPnP现在正在与LumenPnP通信。
如果机器无法连接
  1. 请查看以下内容:
    • 机器电源已开启
    • USB线已经连接上了并插紧
    • 选择正确的串口,如果不知道是哪个串口,可以挨个尝试连接
    • 没有其他软件占用该串口
    • 极少数情况是使用了USB集线器/扩展器,请直接连接电脑usb端口,或更换USB集线器
    • 极少数情况是电脑原因,可以更换电脑尝试连接
  2. 重启 OpenPnP 也有助于刷新可用端口。

连接摄像头

视频教程

取下相机镜头盖

  • 请确保两个相机的镜头盖的镜头盖已取下,部分可能运输中已经掉落了。能看到玻璃镜头就行。

连接顶部摄像头

  1. 导航至:Machine Setup > Heads > ReferenceHead H1 > Cameras > OpenPnpCaptureCamera Top
  2. 打开Device Settings 标签页。
  3. 定位 Device dropdown
    • 选择LumenPnP Top相机
  1. 请找到Format,打开下拉菜单
  2. 然后选择格式:
    • 1920x1080, 30FPS, MJPG
  3. 如果相机无法连接,请尝试:
    • 1920x1080, 5FPS, YUYV
  4. 点击Capture FPS 旁边 的Test。这将:
    • 应用上面所选格式
    • 开始捕获摄像机画面
    • 自动应用设置

打开补光灯

在相机画面右上角,单机灯光图标,打开相机补光灯 图片展示的是连接顶部摄像头时的相机界面。画面中央有一个靶心,靶心内有蓝色的球体。右上角有太阳图标,旁边有红色箭头指向该图标。左下角显示“Top”字样。该图片与文档中“连接顶部摄像头”部分相关,用于辅助说明在连接顶部摄像头时,如何在相机界面进行操作,如调整曝光模式等。

确认相机设置

请验证以下相机属性是否和我们自己的一致:

设置曝光模式

要将相机切换到手动曝光模式:
  1. 在相机属性中,找到Exposure曝光这一行。勾选旁边的复选框(如果已经勾选了,请取消勾选,然后再勾选)。
  2. 再次取消勾选你刚刚点击的复选框(这里反复勾选是为了确保曝光设置能被正确保存。)。
  3. 然后将数值拖动到最小值(必须修改数值,才会生效) 图片展示了相机属性中Exposure曝光设置界面。画面中有复选框、数值输入框及滑动条。复选框左侧有黑色箭头指向,右侧绿色箭头指向滑动条,滑动条上有蓝色箭头指向数值“-5”。该图片与文档中“设置曝光模式”步骤相关,用于说明在相机属性中勾选Exposure曝光复选框后,再次取消勾选并拖动数值到最小值的操作,以确保曝光设置能被正确保存。

调整相机顶部曝光

设置 曝光值=100(Linux),曝光值=-1(Windows)作为起点。 你可能需要用机器控制面板移动贴装头到主教准本上方, 然后调整曝光值,让相机看到主校准板的线框。

连接底部摄像头

  1. 导航至:Machine Setup > Cameras > OpenPnpCaptureCamera Bottom
  2. 打开Device Settings 标签页。
  3. 定位到Device,打开下拉菜单
  4. 然后,从列表中选择LumenPnP Bottom摄像头。
  5. 请找到Format,打开下拉菜单
  6. 然后选择格式:
    • 1920x1080, 30FPS, MJPG
  7. 如果相机无法连接,请尝试:
    • 1920x1080, 5FPS, YUYV
  8. 点击Capture FPS 旁边 的Test这将:
    • 应用上面所选格式
    • 开始捕获摄像机画面
    • 自动应用设置

打开补光灯

在相机画面右上角,单击灯光图标,打开相机补光灯 图片展示的是连接底部摄像头时,打开补光灯的操作界面。画面中有一个靶心图案,靶心内有蓝色的球体。右上角有一个灯光图标,图标内有太阳图案,旁边有红色箭头指向,且图标右侧有一个开关,处于关闭状态。该图片与文档中“打开补光灯”步骤相关,直观呈现了在相机画面右上角单击灯光图标后,灯光开关的状态,帮助用户了解操作位置和效果。

确认相机设置

以下所有设置在调整曝光前都保持不变,直到调整曝光时才有细微差别。 使用与顶部摄像头相同的属性值:

设置曝光模式

要将相机切换到手动曝光模式:
  1. 在相机属性中,找到Exposure曝光这一行。勾选旁边的复选框(如果已经勾选了,请取消勾选,然后再勾选)。
  2. 再次取消勾选你刚刚点击的复选框(这里反复勾选是为了确保曝光设置能被正确保存。)。
  3. 然后将数值拖动到最小值(必须修改数值,才会生效) 图片展示了相机属性中Exposure曝光设置界面。画面中有复选框、数值输入框和滑动条。复选框左侧有黑色箭头指向,表明操作重点。数值输入框显示当前值为-2.5,滑动条右侧有蓝色箭头,指向-5。该图片与上下文紧密相关,上下文介绍了将相机切换到手动曝光模式的操作步骤,此图直观呈现了操作中需取消勾选复选框并拖动滑动条至最小值的环节。

调整底部相机曝光

设置 曝光值=100(Linux),曝光值=-1(Windows)作为起点。 你可能需要用机器控制面板调整贴装头位置,让相机看到吸嘴作为参考点。 图片展示的是底部摄像头拍摄的图像,画面中有一个蓝色的吸嘴,吸嘴尖端被红色十字线框住,周围有红色的刻度线。画面左下角显示“Bottom”标识。该图与文档中“连接底部摄像头”及“调整底部相机曝光”内容相关,用于辅助说明调整曝光值后,通过底部摄像头拍摄的吸嘴图像情况,以验证摄像头功能是否正常。

回零LumenPnP

视频教程

为什么回零很重要

回零会为机器设定已知的起始位置。 在回零过程中,LumenPnP 将贴装头移动到位于机器的 X、Y 和 Z 零位置,即前左角(X0, Y0)处。

回零之前

按下Home键前,先确认吸嘴水平。 图片展示了LumenPnP机器控制面板中的“Home回零”操作界面。画面中,“Home回零”按钮以红色框和箭头突出显示,位于“Machine Controls”面板内,其左侧是红色的“Power”按钮,右侧是“P”形的“Jog”按钮。该图片与文档中“执行回零操作”部分内容相关,直观呈现了按下“Home回零”按钮前的操作界面,帮助用户明确找到回零按钮的位置,以便进行回零操作。 图片展示了LumenPnP机器的贴装头部分。机器主体为黑色,贴装头位于画面中央偏右位置,其上有多个连接线,包括黄色、蓝色等。贴装头下方有一个小孔,可能是用于放置贴片的。背景为红砖墙,墙上有黑色的金属轨道。该图片与文档中“执行回零操作”部分相关,用于直观呈现按下Home键前机器贴装头所在位置,辅助理解操作前机器状态。

执行回零操作

  1. Machine Controls面板中找到Home回零按钮。
  1. 点击 黄色的Home回零 图标
    • 机器会把贴装头移到机器的前左角(X0, Y0)位置。
    • 动作完成后,贴装头将停留该位置。

安装吸嘴

视频教程

准备吸嘴头

LumenPnP使用CP40吸嘴。 校准时,我们将使用三个吸嘴头(N045、N08和N24)。我们开始时会先在机器上安装其中两个吸嘴头。
  1. 在首次安装吸嘴头前,先轻轻润滑O型圈。
    • 在吸嘴杆上涂少量润滑剂,并多次插入或取出头头以均匀涂抹。
    • 只需少量,但务必确保头完全覆盖,且头上不留多余的材料。

安装N045吸嘴头

我们将安装以下吸嘴头以开始校准: 当选择此选项时:
  • LumenPnP会将贴装头移向靠近你的位置。
  • 弹窗将出现一条信息
  • 这是正常现象,它只是暂停移动,让你安装吸嘴尖端。单击 OK 忽略。

将N045吸嘴头安装到N1吸嘴上

  1. 将N045吸嘴头推到N1号吸嘴杆上,直到它平稳地贴合O型圈。
  2. 不需要太用力。需要时涂抹润滑。

装填N24吸嘴头

对第二个吸嘴重复同样的过程。
  1. 导航至:Machine Setup → Heads → ReferenceHead H1 → Nozzles → ReferenceNozzle N2 → Nozzle Tips
  2. 勾选N24的吸嘴头Loaded?复选框。

将N24吸嘴头安装到N2吸嘴上

  1. 将N24吸嘴头推到N2号吸嘴杆上,直到它平稳地贴合O型圈。
  2. 不需要太用力。需要时涂抹润滑。

相机曝光和补光灯亮度调节

视频教程

调整LED亮度值并打开

  1. 机器配置 -> 驱动定义-> DcodeDriver -> Gcode
    • 组件选择:LED
    • 设置项选择:ACTUATE_BOOLEAN_COMMAND
    • 将下方 M150 P255 V255 R255 B255 中的 P255 改为 P45。应用保存。数字越大越亮。范围0-255
  1. 在相机画面右上角,单击灯光图标,重新打开相机补光灯启用修改(否则修改将不起作用)

调整顶部相机曝光

  1. 将顶部摄像头移动到主校准板上方
  • 使用Machine Controls微调Cameera:Top(Head:H1),使之大致位于基准板正上方中心位置。
  • 如果发现您的机器没有移动,请将滑块Distance设置为 110
  • 相机画面右键,打开Ruler辅助十字线。使用0.10.01Distance,将摄像头的十字线精确地调整到主校准板中心圆上方。您可以使用鼠标滚轮放大画面,以获得更高的精度。
  1. 导航至Machine Setup > Heads > ReferenceHead H1 > Cameras > OpenPnPCaptureCamera Top
    1. 在下方详细信息窗格中,切换到Device Settings该选项卡。
  1. 找到Saturation饱和度,将值改为0(画面将变成黑白,更利于软件后续的识别)
  1. 右键单击顶部摄像头画面,选择Show Image Info?启用图像信息卡。这将显示图像的亮度直方图。
  • 请将直方图作为一般参考,而非精确测量。它虽然是一个有用的工具,但并不精确。为了获得最佳效果,请参考下方的对比照片,这些照片展示了“过亮”、“过暗”和“曝光良好”的示例,以帮助您在使用直方图后微调设置。
  • 请将直方图作为一般参考,而非精确测量。它虽然是一个有用的工具,但并不精确。为了获得最佳效果,请参考下方的对比照片,这些照片展示了“过亮”、“过暗”和“曝光良好”的示例,以帮助您在使用直方图后微调设置。
  • 下一步,我们的目标是在直方图的右侧形成一个尖锐的峰值,并在左侧形成一个较大的聚集区域。请参考下图。
  1. 找到正确的曝光量
  • 调整Exposure和Saturation滑块或手动输入不同的值,以确保相机能够清晰看到中心圆,从而进行校准。目标是使图形轮廓线区域最亮且清晰可见但不至于完全变成白色,同时板子黑色区域也尽可能暗淡但不至于完全黑色。请参考以下图片调整曝光:
  • 使用完毕后,请关闭直方图窗口。用打开直方图视图的相同方法将其关闭。
  1. 记录底部摄像头曝光值
  • OpenPnP 重启后可能无法保留您的相机曝光设置。请将曝光值记录并保存到文本文件中或用笔写下来。
  • 这意味着每次启动 OpenPnP 时,您都必须:
    • 手动关闭自动曝光模式 。(这会将相机切换到手动曝光模式)
    • 在滑块旁边的曝光字段中输入您记录的曝光值
  1. 应用并保存
  • 请点击Apply右下角保存更改。(OpenPnP 中该按钮可能显示为灰色,这没关系。)
  • 立即保存您的 OpenPnP 配置File > Save Configuration

测试顶部相机识别

进入 机器配置 > 全局视觉 > Fiducal Locator。选择基准视觉配置选项卡 找到视觉通道,单击编辑按钮 你的默认画面中,校准板中心圆周围应该有一个绿色圆圈,表示软件已经识别到中心圆了。 如果没有,右上角关闭,返回前面步骤重新调整曝光值。直到识别正确。

调整底部相机曝光

  1. 选择吸嘴:N1
    • Machine Controls下拉菜单中选择Nozzle: N1 - N045 (Head:H1)
  1. 将“吸嘴:N1”定位在底部摄像头上方
  • 使用Machine Controls微调Nozzle: N1,使之大致位于基准板上方位置。
  • 如果发现您的机器没有移动,请将滑块Distance设置为 110
  • 当您需要更精确的移动时,请将滑块Distance设置为 0.10.01
  • 降低Nozzle: N1吸嘴Z高度,直至吸嘴尖端几乎接触基准板。将吸嘴降低到与基准板相同的高度,可确保在校准前吸嘴处于正确的 Z 轴高度。
  • 保持 Z 轴高度不变,微调Nozzle: N1使其居中对准底部摄像机画面中心
  • 在相机画面右键,打开Ruler辅助十字线。使用0.10.01Distance,将吸嘴尖端位置精确地调整到摄像头的十字线正上方。您可以使用鼠标滚轮放大画面,以获得更高的精度。
  1. 调整底部摄像头曝光
  • 返回Machine Setup > Cameras > OpenPnpCaptureCamera Bottom 标签页Device Settings
  • 找到Saturation饱和度,将值改为0(画面将变成黑白,更利于软件后续的识别)
  • 右键单击底部摄像头画面,选择Show Image Info?启用图像信息卡。这将显示图像的亮度直方图。
  • 请将直方图作为一般参考,而非精确测量。它虽然是一个有用的工具,但并不精确。为了获得最佳效果,请参考下方的对比照片,这些照片展示了“过亮”、“过暗”和“曝光良好”的示例,以帮助您在使用直方图后微调设置。
  • 下一步,我们的目标是在直方图的右侧形成一个尖锐的峰值,并在左侧形成一个较大的聚集区域。请参考下图。
  1. 找到正确的曝光量
  • 调整Exposure和Saturation滑块或手动输入不同的值,以确保相机能够清晰地检测到吸嘴尖端的暗孔,从而进行校准。曝光应保持平衡,既要足够明亮以区分吸嘴尖端和背景,又不能太亮以至于难以辨认暗孔。目标是使最亮的区域清晰可见但不至于完全变成白色,同时较暗的区域也保持轮廓分明。请参考以下图片调整曝光:
  • 使用完毕后,请关闭直方图窗口。
  1. 记录底部摄像头曝光值
  • OpenPnP 重启后可能无法保留您的相机曝光设置。请将曝光值记录并保存到文本文件中或用笔写下来。
  • 这意味着每次启动 OpenPnP 时,您都必须:
    • 手动关闭自动曝光模式 。(这会将相机切换到手动曝光模式)
    • 在滑块旁边的曝光字段中输入您记录的曝光值
  1. 应用并保存
  • 请点击Apply右下角保存更改。(OpenPnP 中该按钮可能显示为灰色,这没关系。)
  • 立即保存您的 OpenPnP 配置File > Save Configuration

测试底部相机识别

  1. 请先 安装吸嘴,如果已经安装则忽略这一步
  2. 移动N045吸嘴尖端几乎接触基准板,然后保持高度不变,将吸嘴移动到底部相机十字线中心
  1. 然后导航到 机器配置 > 吸嘴列表 > N045。点击吸嘴校准 选项卡,单击 视觉通道 按钮
  1. 默认界面,画面中的绿色圆圈应该不在吸嘴尖端暗孔上,表示机器没有识别到中心圆孔
  1. 我们在左上角单击 cir 行,将maxDiameter数值改为20(你的可能会稍大,30以内都是可以的),此时右侧画面的绿色圆就和吸嘴中心孔重叠了,表明软件识别到了中心孔。
    1. 右上角点击 x。关闭弹窗。如果你没识别到,也执行关闭。
  • 如果识别正确,选择:是。
  • 如果识别错误,选择:否。并返回前面步骤重新调整曝光值。直到识别正确。

视觉归位

设置回零基准位置

  1. 导航至 Machine Setup > Heads > ReferenceHead H1
在**“配置”选项卡中,将“回零方式”更改为ResetToFiducialLocation。这样就修改了回零方式**,机器会先机械归位,之后顶部相机会移动到基准点上方并识别,纠正限位开关造成的任何轻微误差。
  1. 应用并保存
  • 点击Apply右下角保存更改。
  1. 点击下方所示的**“将相机定位到目标位置”**图标按钮。
  • 这样就将顶部摄像头移动到基准板上方的大致位置。
  1. 调整顶部摄像头:
  • 在 OpenPnP 的左下角,使用微调控件将十字线中心对准基准点的正中心。
  1. 现在我们已经完全对准了回零基准点
  • 返回 Machine Setup > Heads > ReferenceHead H1
  • 点击Capture Camera Location按钮保存回零基准点的位置。
  1. 应用并保存
  • 点击Apply右下角保存更改。

测试基准回零

  1. 点击“回零”按钮,机器完成左下角的机械归位后,会继续将顶部摄像头移动到主校准板的圆点上方,并试图找到其确切位置。当摄像头扫描到标记时,会呈现红色,表示正在扫描标记的圆圈。
如果扫描到远点,机器会自动再次微调位置,知道十字准心完全对准原点中心,即完成了一次精确的视觉归位。这个比简单的机械归位更准确,不会出现因机械限位不准导致归位后位置偏移的情况。
  1. 如果您收到此错误FIDUCIAL-HOME no matches found,则表示 OpenPnP 无法找到您的回零基准点。您需要调整相机曝光或者回零基准点管道

OpenPnP概述

了解OpenPnP界面


机器控制概述

位于OpenPnP的左下角 每个机器控制标签页及其功能解析:
Jog Tab点动标签页(默认)
  1. 电源键
  2. Home回零按钮(成功连机器时变为黄色)
  3. 吸嘴下拉菜单选择(N1和N2之间切换)
  4. X/Y 点动控制(在 x 轴和 y 轴上点动移动贴装头)
  5. Z 点动控制(上下垂直点动移动机器头)
  6. C 点动控制(旋转选中的吸嘴。使用这些控制时,距离mm会转换为旋转度数deg)
  7. 点动距离滑块(允许调整点动距离。)

Special特别标签页
  • 回收元器件
  • 丢弃吸取的元器件

Actuators执行器标签页
  • 手动开关LED灯
  • 手动开启并读取真空泵


校准准备

校准到底是做什么的?

在我们开始浏览“问题与解决方案”(OpenPnP自带的校准步骤)之前,了解校准的实际作用,包括一些重要提示,这很有帮助。 校准不是单一的调整。这是一个分层的过程,教会机器物理空间、摄像空间和运动空间之间的关系。

为什么我们只执行特定的校准步骤

问题与解决方案包含三种步骤:
  • 基本步骤(开始时,只完成我们列出的步骤)
  • 建议步骤(在我们完成验证 基本步骤 之前,不要执行这些步骤)
  • 错误步骤(在我们的配置文件中,会显示一些标注为错误的步骤,校准时忽略。)
OpenPnP 包含许多校准工具,旨在支持各种类型的机器。 LumenPnP在机械设计上遵循特定的工作方式,工作流程也遵循该设计。 我们只执行LumenPnP所需的步骤,避免某些会导致问题的步骤。 运行无关步骤可能会带来问题或校准数据冲突。

接下来会发生什么

下一节我们将开始使用OpenPnP的问题与解决方案进行校准过程。 每一步都会引导你调整摄像头、吸嘴和机器设置,直到一切正确对齐。 校准完成后:
  • 机器能正常定位
  • 吸嘴尖端始终与相机的十字准星对齐
  • 反复移动回到同一位置
  • 放置精度在视觉上保持一致
慢慢来。每一步都在上一个基础上逐步推进,最终需要的知道会越来越少,因此认真掌握基础知识非常重要。
你已经完成了预检! 下一步 现在我们将开始使用OpenPnP的问题与解决方案进行引导校准过程 问题与解决方案→
  1. 弹窗提醒界面选择
  2. 首先,请前往:Machine Setup → Heads → ReferenceHead H1 → Nozzles → ReferenceNozzle N1 → Nozzle Tips
  3. 勾选 N045 吸嘴头的Loaded?复选框